View Your Cart
Royalty Free Music Unique To Your Project - Every Time
SmartSound Support: : Avid Media Composer Bundle: Serial # won't work

Avid Media Composer Bundle: Serial # won't work

Back to regular version

New serial numbers that are being shipped with the Avid Media Composer bundle require Sonicfire Pro version 5.5 or greater. Some boxes shipped with the earlier 5.1 version of Sonicfire Pro, which will not recognize some of the newer serial numbers.

The solution is update your Sonicfire Pro 5 software to the latest version. You can download the latest patch file here.

Download and install the patch update first, then enter your serial number and it should unlock.