View Your Cart
Royalty Free Music Unique To Your Project - Every Time
Sonicfire Pro 2 in Mac 10.3
Sonicfire Pro 2 in Mac 10.3
By admin

Since you have upgraded to Mac OS X.3 (Panther), you now have a version of QuickTime newer than v.6.3. Sonicfire Pro 2.x is not compatible with the newer versions of QuickTime due to the drastic changes made by Apple to accommodate the release of iTunes, iLife and Panther.

The only solution to this problem is to purchase Sonicfire Pro version 4. For more information about Sonicfire Pro 4, please visit

Submitted: 09/17/09

Views: 380 views. Averaging 0 per day.
In the most recent 30 day period, there've been 3 views.

Similar Articles:
Do I need Sonicfire Pro 5?
Does Sonicfire Pro work with my NLE?
Can I Download Sonicfire Pro?
QuickTime 7 & Sonicfire Pro
Sonicfire Pro 5 System Requirements

Previous Article | Next Article